Improve RFC links (#8612)

The `tools.ietf.org` site now redirects to `www.rfc-editor.org`.
* Update various URLs to the new site.
* Make links to `www.rfc-editor.org` consistent.

Signed-off-by: SuperQ <superq@gmail.com>
This commit is contained in:
Ben Kochie
2026-10-08 10:21:06 +02:00
committed by GitHub
parent 763bdb9b76
commit 311a9915da
60 changed files with 1006 additions and 215 deletions

View File

@@ -1,9 +1,9 @@
.\" Generated by Mmark Markdown Processor - mmark.miek.nl
.TH "COREDNS-SIIT" 7 "August 2026" "CoreDNS" "CoreDNS Plugins"
.\" Generated by Mmark Markdown Processer - mmark.miek.nl
.TH "COREDNS-SIIT" 7 "October 2026" "CoreDNS" "CoreDNS Plugins"
.SH "NAME"
.PP
\fIsiit\fP \- enables AAAA\->A translation support for DNS records based on SIIT (IPv6\->IPv4 translation).
\fIsiit\fP - enables AAAA->A translation support for DNS records based on SIIT (IPv6->IPv4 translation).
.SH "DESCRIPTION"
.PP
@@ -11,10 +11,10 @@ The \fIsiit\fP plugin will when asked for a domain's A record,
synthesizes it from a corresponding AAAA record if it belongs to a certain IP range.
.PP
It also supports arbitrary mapping IPv6\->IPv4.
It also supports arbitrary mapping IPv6->IPv4.
.PP
It is useful when published services are IPv6\-only and emit their AAAA record accordingly
It is useful when published services are IPv6-only and emit their AAAA record accordingly
but IPv4 clients reach them through a siit routing. This plugin generates the associated A records
for these clients automatically.
@@ -56,7 +56,7 @@ siit {
If monitoring is enabled (via the \fIprometheus\fP plugin) then the following metrics are exported:
.IP \(bu 4
\fB\fCcoredns_siit_requests_translated_total{server}\fR \- counter of DNS requests translated
\fB\fCcoredns_siit_requests_translated_total{server}\fR - counter of DNS requests translated
.PP
@@ -67,15 +67,15 @@ The \fB\fCserver\fR label is explained in the \fIprometheus\fP plugin documentat
Prefix matching in eam is not implemented yet.
.IP \(bu 4
DNSSEC support is not implemented yet. The problem is the same as DNS64. See: RFC 6147 Section 3
\[la]https://tools.ietf.org/html/rfc6147#section-3\[ra]
\[la]https://www.rfc-editor.org/info/rfc6147/#section-3\[ra]
.SH "SEE ALSO"
.PP
See RFC 6052
\[la]https://tools.ietf.org/html/rfc6052\[ra] for more information on the SIIT mechanism
\[la]https://www.rfc-editor.org/info/rfc6052/\[ra] for more information on the SIIT mechanism
and RFC 7757
\[la]https://tools.ietf.org/html/rfc7757\[ra] about the explicit address mappings (eam) mechanism
\[la]https://www.rfc-editor.org/info/rfc7757/\[ra] about the explicit address mappings (eam) mechanism
.SH "NOTES"
.PP